John Yassa's Blog

Home » Posts tagged 'owa'

Tag Archives: owa

Publish Multiple OWA & ECP Virtual Directories on one Exchange 2010 CAS Server

Suppose you host more than one domain at your Exchange server , and each company need to have its OWA URL , below is steps how you can implement more than one OWA & ECP on one Exchange 2010 server

1- Create a new WEB SITE
– New IP
– Ports 80 / 443
– Name WebMAIL
– Default Path – C:\inetpub\wwwroot

2- Install Certificate (HTTPS) for External User

3- Copy the Folders:
C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Owa
C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\ecp
to
Ex:
C:\Program Files\Microsoft\Exchange Server\V14_domainname\ClientAccess\Owa
C:\Program Files\Microsoft\Exchange Server\V14_domainname\ClientAccess\ecp

4- ON IIS – ISAPI and CGI Restrictions
Give Permission ALLOW to this DLL
C:\Program Files\Microsoft\Exchange Server\V14_domainname\ClientAccess\Owa\auth\owaauth.dll

5- On Exchange Power Shell
new-owairtualDirectory -WebSiteName “WebMAIL” -Path “C:\Program Files\Microsoft\Exchange Server\V14_domainname\ClientAccess\Owa”

New-ecpVirtualDirectory -WebSiteName “WebMAIL” -Path “C:\Program Files\Microsoft\Exchange Server\V14_domainname\ClientAccess\ecp”

6- Fix Virtual Directory Path
Exchange
Exchweb
Public
In IIS – change – The Virtual Directory Path
….\V14\ClientAccess\Owa
to
….\V14_domainname\ClientAccess\Owa

7- In Exchange Console
– Server Configuration > Client Access > <server> > Outlook Web APP > owa (Mail) > Properties Authentication > Use one or more standard authentication methods > FBA

– Server Configuration > Client Access > <server> > Exchange Control Panel > ECP (Mail) > Properties Authentication > Use one or more standard authentication methods > FBA

8- Reset IIS

Now try to browse the URL of the new OWA

Exchange 2010 SP1 or SP2 OWA page not load after IIS reset

If you make a change in IIS, you need to reset IIS you just simply do IISRESET
This works on all other OWA or other servers, but on Exch2010SP1 or Exch2010SP2 after IISRESET owa page will not load,
after reboot the server all works fine.

IISReset.exe fails to stop the IIS services in a timely fashion. With the /NOFORCE switch included, IISReset.exe will not attempt to forcibly shut down the IIS services if the services do not stop gracefully.

Instead of using IISRESET you use net stop and net start command as below

C:\>NET STOP w3svc
The World Wide Web Publishing Service service is stopping.
The World Wide Web Publishing Service service was stopped successfully.
C:\>NET START w3svc
The World Wide Web Publishing Service service is starting.
The World Wide Web Publishing Service service was started successfully.

To stop and start the IIS Admin Service, run the following commands:
C:\>NET STOP iisadmin /y
The following services are dependent on the IIS Admin Service service.
Stopping the IIS Admin Service service will also stop these services.
World Wide Web Publishing Service HTTP SSL

The World Wide Web Publishing Service service is stopping.
The World Wide Web Publishing Service service was stopped successfully.
The HTTP SSL service is stopping. The HTTP SSL service was stopped successfully.
The IIS Admin Service service is stopping..
The IIS Admin Service service was stopped successfully.

C:\>NET START w3svc
The World Wide Web Publishing Service service is starting.
The World Wide Web Publishing Service service was started successfully.

 

 

%d bloggers like this: